Issue
After DS Software update Pelco Mobile no longer connects.
Pelco Mobile errors: Login failure/Connection failed.
Event Viewer: Application error 18456
Product Line
Pelco Video Management
Environment
- DS v7.12
- DSSRV/2 v7.12
- DS NVs v7.12
- Pelco API Bundle v7.12
- Pelco Mobile
Cause
Pelco Mobile will not connect with Pelco API Bundle even though ports are open, telnet is successful and netstat -ano is listening due to a login failure.
Login failure with SerenityAPI: Go to C:\Users\DSNVSUser\AppData\Local\Pelco\DSSerenityAPI
Open the SerenityAPIService with Notepad, scroll down to the bottom of the text file and you will see "Time stamp SerenityAPI: IntegralSystem exception: Login failed for user admin."
Resolution
Manually copy the DSServiceUser ControlPointCache file replace the DSNVSUser ControlPoinCache file.
- Verify all user accounts have the correct usernames and passwords in DS Admin.
- Login to DS ControlPoint with the admin account and verify connection / live video.
- Close DS ControlPoint
-
Go to Start > Type %appdata% > Select Roaming (if two are listed select the first Roaming folder)
- Double Click Pelco and right click on ControlPointCache and select Copy
- Click on the Computer on the left hand side go to > C:\Users\DSNVSUser\AppData\Roaming\Pelco (If you do not see AppData, enable Show hidden files, folders and drives)
- Paste and replace ControlPointCache file.
- Close all open windows.
- Restart the DigitalSENTRY FrameServer Service
-
Wait two minutes after the service restarts for all connections to update then verify Pelco Mobile connection
- If Pelco Mobile fails to connect restart Server