VideoXpert: 1.8 Cluster Restoration

NOTICE

POTENTIAL FOR DATA LOSS.
The steps detailed in the resolution of this article may result in a loss of critical data if not performed properly. Before beginning these steps, make sure all important data is backed up in the event of data loss. If you are unsure, please contact Product Support Services prior to attempting the procedure below.

Issue

Replacing a Core within a Cluster which has failed.

Product Line

Pelco Video Management

Environment

Core v1.8

Gateway v1.7

Ops Center v1.8

Accessory Server v1.0

Cause

Core/CMG which has failed within a clustered environment.

Resolution

1. The replacement unit should have the following items configured: (They should match the CMG that is being replaced.)

  • Computer Name
  • IP Address
  • NTP/Meinberg (IMPORTANT:Time on replacement unit must match that of the functional Core)
  • Activate Windows

2. Go to http://x.x.x.x:8080/haproxy_stats -> Replace x.x.x.x with the IP Address of the Accessory Server -> EXAMPLE: http://192.168.5.100:8080/haproxy_stats

3. Under "core servers", check the box for the CMG that is down.

4. In the Drop Down Box for "Choose the action to perform on the checked servers," Select "Set state to MAINT" and click Apply.

5. Check Core for MAINT Mode by checking the Color Change.  See Figure Below for details.

6. Install Core and Media Gateway Packages on the replacement Hardware but DO NOT Configure them.  ***During the install of the Media Gateway you will need to specify the VIP address to be used when prompted for the Server Address.***

7. Create a Folder named Restore on the root of the C:\ Drive.

8. Copy the "restoreutil.jar" to C:\Restore 

Restore Utilitiy Download 

9. Open a Command Window and type the following:

cd C:\Restore, Hit Enter

10. Type the following command from C:\restore to start the Manual Sync from the Active(Funcional) CMG:

***DO NOT COPY AND PASTE THIS COMMAND, Please type in the command manually.***

COMMAND: "c:\Program Files\Pelco\Core\jre\bin\java.exe" -cp restoreutil.jar;"C:\Program Files\Pelco\Core\core\vmscore-fat.jar" com.pelco.vms.webService.tools.dbRecovery.RestoreUtil --coreIp x.x.x.x

EXAMPLE: "c:\Program Files\Pelco\Core\jre\bin\java.exe" -cp restoreutil.jar;"C:\Program Files\Pelco\Core\core\vmscore-fat.jar" com.pelco.vms.webService.tools.dbRecovery.RestoreUtil --coreIp 192.168.10.100

11. Hit Enter to initiate the script, allow for the script to finish before moving onto the next step.

12. Upon completion of Script you will see the following output, see red highlighted Output string:

13. Verify that the Core service is running on the newly restored Core, see below figure:

14. Wait 15 minutes for the Database Sync to complete before moving onto the next steps.

15. Go to http://x.x.x.x:8080/haproxy_stats -> Replace x.x.x.x with the IP Address of the Accessory Server -> EXAMPLE: http://192.168.5.100:8080/haproxy_stats

16. Under "core servers", check the box for the CMG that was previously set to Maintenance Mode.  In the drop down box for "Choose the action to perform on the checked servers," Select "Set state to READY" and click Apply.

17. Use the Refresh Option to update the page.  Both Core servers should show up as Green at this point.