VideoXpert: Download reports from Admin Portal

Issue

Technical Support or the supervisor onsite need to review specific reports.

Product Line

Pelco Video Management

Environment

VideoXpert version 1.8

Cause

An administrator needs to audit the system and users.

Resolution

From the Reports tab you can download reports from the system. Reports are exported in CSV format contained within a ZIP archive. Reports using the clock symbol require a start date and time; other reports provide current data. Generating reports containing a large number of events may take some time. You can navigate away from the Reports tab while the system generates your report. If your report parameters are too large the request may time out and the system may ask you to narrow your search.
 
Note: In all reports, cameras and other devices connected through Digital Sentry servers display the IP address of the DS server through which they are connected rather than their direct IP address.
 

Event Types (The complete list of events in the User Actions report is in the VideoXpert Admin Portal User Guide)
  • Admin events typically occur at the administrative level.
  • Analytic events are the result of software analytics.
  • Client events that are reported by the client.
  • External event which are injected into the system by a third party
  • Hardware events resulting from physical hardware issues and sensor readings
  • System events are typically the result of normal operator actions

     

Report Descriptions:

  • Camera Configuration: This report provides the address, name, and number (if set) for cameras in the system (appearing on the Devices page in the Admin Portal), and the recorders to which each camera is assigned.
  • Online/Offline: This report provides a list of all device_online and device_offline events happening in the time frame you specify with relevant details for devices associated with each event.
  • Recorder Camera Assignment: This report contains the complete list of recorders and the video sources assigned to each recorder. It contains similar information to the Camera Configuration report, but is sorted by recorder.
  • Recorder Diagnostics: This report provides the current status and health of your VideoXpert recorders, including hard drive status.
  • User Actions: This report lists the events in the system for which users are directly responsible within VideoXpert. For example, the report would not show a device_offline event, but would show a device_decommissioned event, listing the user responsible for decommissioning the device. The complete list of events in the User Actions report is in the VideoXpert Admin Portal User Guide.
  • Event History: This report provides a complete list of all events that occurred within the time frame you specify, including the source of the event (device, user, etc) and the state of the event (acknowledged, in progress, etc.).
  • VX Cluster Configuration: This report provides a list of the Core and Media Gateway servers in your VideoXpert system and their online or offline status.
 
  1. Login to Admin Portal using [Username: admin Password: site_specific_password].
  2. Click Reports.
  3. Select the reports you want to download.
  4. Set start and end dates for the report you want to download. Reports based on events logged byt he system must be captured within the event-retention time period; by default the system stores events for 30 days.
  5. Click Export Reports.



     
  6. After clicking 'Export Reports...', wait
    • keep waiting
    • keep waiting
    • keep waiting
    • there is no status indicator or anything to tell you the process is working or not
    • eventually, your browser will show it is downloading a 'QuickReports' file