Issue
- AMT Windows locking up the PC
- Too many active windows opening in AMT causing the PC to hang
- AMT stops working
Product Line
TAC INET
Environment
I/NET Seven 2.30 and below.
Cause
In AMT each Critical, Priority, Routine, Messages or Transactions button opens a new window on each press. On the surface it appears to switch between these windows. Along with this all open windows and positions are retained for each user login, hence this will cause different results for different users. A problem eventually occurs when there are too many active windows open in AMT.
Resolution
In most cases the problem is due to a user having opened too many AMT windows but you could also verify the following:
- Verify that you have only the default windows opened.
- Not more than one of the same window opened (usual symptom).
- If filtering is done, allow the filter opened to fill the screen.
- Check the rights for the Logged on user if they have window controls in Host Passwords.
- If you have multiple users, and are able to log in without AMT hanging then, recreate the other user account and delete the first one.
If the problem is still occurring, please use the attached SQL script. The script resets the window positions of ALL windows to default for ALL of the operators in the I/NET database. This will fix the issue.
- Close I/NET completely
- Copy this file to your desktop: AMT Reset.ZIP
- Unzip and run the file
- It will ask for a logon, this is your sa user name and password
Once run, this will have reset the AMT screen and the system should run again.