VideoXpert: Updating a brand new(not configured) Core results in an installation error

Issue

Customer receives an error message when updating core service on a system that has never been configured.

 

Product Line

Pelco Video Management

Environment

  • VideoXpert
  • VX Core 1.8 and 1.9

Cause

The installer recognizes that a previous version is installed therefor tries to update the mongo database which is not running yet. 

Resolution

Current workaround:

  1. Uninstall Core 1.8 
  2. Delete the directory C:\Programdata\pelco\core
  3. Install Core1.10