Issue
A procedure to monitor the SM5200 Input/Output is required
Product Line
Pelco Video Management
Environment
- I/O Check Utilitiy
- SM5200 All Models
Cause
SM5200 Input/Output monitoring is needed
Resolution
Note: Parts I, II, & III of this article only need to be ran once. Every step in Parts IV and V will need to be ran each time a new io-check is required.
Part I: Download io-check.zip file here: https://schneider-electric.box.com/s/cb1exeszrc5fs3wkr7zt7oar1i63ke4r
Part I: Download io-check.zip file here: https://schneider-electric.box.com/s/cb1exeszrc5fs3wkr7zt7oar1i63ke4r
Part II: Create the io-check directory on the SM5200
1. ssh into the SM5200
2. type mkdir /home/pelco/io-check
Part III: Copy the files to the SM5200
1. Unzip the io-check.zip file, extracting the contents of the io-check.zip file to a designated location

2. Right click on the SM5200, select SCP, then choose Copy files to

3. Choose each file one at a time. Each time add the Remote path /home/pelco/io-check then click OK

3. Choose each file one at a time. Each time add the Remote path /home/pelco/io-check then click OK
- header.pl
- io-check.sh
- iodump_mod.pl

Part IV: Run io-check.sh for 24 hours
1. ssh into the SM5200
2. type cd /home/Pelco/io-check
3. type echo 1 > /proc/sys/vm/block_dump
4. type sh io-check.sh
5. Enter h for hours
6. Enter 24. The message Beginning I/O data collection... will display on the monitor. To abort the io-check utilitiy, press ctrl+z


7. Leave the putty window open. When the data collection is completed you will see a message “Data collection complete”


Part V: Copy the results from SM5200 to the Desktop
1. Right click on the SM5200, select SCP, then choose Copy Files from

1. Right click on the SM5200, select SCP, then choose Copy Files from

2. Enter the Remote Path /home/pelco/io-check/results

3. There will now be a folder on the Desktop with the IP address of the SM5200, in this case 192.168.5.10 which will contain the io-check results. Zip this folder and email to the Technical Support Representative reviewing the case.

3. There will now be a folder on the Desktop with the IP address of the SM5200, in this case 192.168.5.10 which will contain the io-check results. Zip this folder and email to the Technical Support Representative reviewing the case.