How to resolve SM5200 ScriptManager, SystemLogger, and other services that are offline

Issue

  1. SM5200 Scriptmanager is offline and fails to restart 
  2. SM5200 SystemLogger is offline and fails to restart 

Product Line

Pelco Video Management

Environment

SM5200 All Versions

Cause

  1. /usr/local/Pelco/XMLScriptInt/Private/Config.xml file size is 0
  2. /usr/local/Pelco/SystemLogger/Private/Config.xml file size is 0

Resolution

To Resolve ScriptManager
ssh into the SM5200
rm –rf /usr/local/Pelco/XMLScriptInt/Private/Config.xml
rm –rf /usr/local/Pelco/XMLScriptInt/Private/Config.xml.bak
rm –rf /usr/local/Pelco/ScriptManager/Private/Config.xml
rm –rf /usr/local/Pelco/ScriptManager/Private/Config.xml.bak
reboot

To Resolve SystemLogger
ssh into the SM5200
rm –rf /usr/local/Pelco/SystemLogger/Private/Config.xml
rm –rf /usr/local/Pelco/SystemLogger/Private/Config.xml.bak
reboot

To Resolve SM5000Locator
ssh into the SM5200
rm –rf /usr/local/Pelco/SM5000Locator/Private/Config.xml
rm –rf /usr/local/Pelco/SM5000Locator/Private/Config.xml.bak
reboot
reboot     hit enter keyrm –rf /usr/local/Pelco/XMLScriptInt/Private/Config.xml   hit enter key
rm –rf /usr/local/Pelco/XMLScriptInt/Private/Config.xml.bak   hit enter key
reboot     hit enter key