VideoXpert does not identify camera inputs on NET5500 series encoder as PTZ cameras.

Issue

VideoXpert is not able to control PTZ cameras connected to NET5500 series encoder.  The cameras appear in the OpsCenter as fixed cameras.

Also, the camera connected to the encoder may appear as a PTZ camera but only the zoom function will work with no pan or tilt control.

Product Line

Pelco Video Management

Environment

  • VideoXpert
  • NET5500 series encoders
    • NET5516
    • NET5508
    • NET5504
    • NET5501

Cause

VideoXpert currently does not have the communication interface necessary to determine whether cameras connected to NET5500 series encoders are configured as PTZ cameras or fixed.

Resolution

In order to configure cameras connected to NET5500 series encoders as PTZ, the NET5500 series encoder user interface (Web UI) must be used to get PTZ working, then use Pelco Utilities to configure the PTZ settings:
Note:If the encoder has already been added and commissioned with the VideoXpert system, decommission the encoder, remove it from the system, go through Pelco Utilities to set PTZ mode, then rediscover and add back to the system. This process will result in video retention loss of previously recorded video for the encoder.

  1. Open Pelco Utilities. Download the latest version here.
  2. Click the "Search" button in the bottom right corener if the list does not automatically populate
  3. Click on the "Devices" tab
  4. Expand the encoder's hierarchy until the list of camera icons is shown
  5. Right-click the camera that corresponds to your PTZ, select device actions, then "Set PTZ Mode..."
  6. In the "Set PTZ Mode" window, configure the camera type and protocol
    1. If Pelco P or D is being used, the baud rate and address must also be configured
  7. If VideoXpert OpsCenter is still running, click the "Refresh Source List" button within Mission Control
    1. If the camera being configured is currently displayed, remove it from the display and then click "Refresh Source List"