VideoXpert: ASCII / PLC Setup

Issue

VideoXpert ASCII Integration is not functioning

Product Line

Pelco Video Management

Environment

  • VideoXpert v2.0.1 Suite
  • VideoXpert ASCII Translator Service version 2.0.7.0
  • .NET Framework 4.61 or later
  • Microsoft Visual C++ 2015 Redistributable (x86)
  • ASCII Integration Service Manual (08/17)

Cause

VideoXpert ASCII Integration setup is required

Resolution

Pre-requisites

  • VideoXpert v2.01 Suite
  • Cameras must be assigned unique numbers. See LL#17819.
  • Dedicated VideoXpert Ops Center setup in Shared Display mode. See LL#18813.
  • Dedicated PC with the following installed in this order:
    • .NET Framework 4.61 or later
    • Microsoft Visual C++ 2015 Redistributables (x86)
    • VideoXpert ASCII Translator Service version 2.0.7.0


Where can I download the Software and Documentation from PDN?  http://pdn.pelco.com/content/asciiplc-downloads#sthash.hT61mrtd.dpbs  User registration to PDN (Pelco Developer Network) is required.


 

Where can I download the Software and Documentation from Pelco Partners First?  http://partnerfirst.pelco.com/content/pelco-schneider-electric#sthash.eHNyzRR6.dpbs  EULA (End User Licensing Agreement is required.

 

How to install the ASCIIVxTranslator Service. (Do not install this service on the VideoXpert Core)
  1. Download and extract ASCIITranslatorService_2.0.7.0.zip file.
  2. Navigate to the Setup.exe file.  Right click then select Install.
  3. Click Next.
  4. Click Install.
  5. Click Finish.
  6. Navigate to the Windows Start button and type services.msc then press Enter.  Right click on ASCII Vx Translator Service and select Properties.
  7. Change the startup type to Automatic then click Apply.  Click Start then OK.

 

How to configure the ASCII Translator Service.
Navigate to the Windows Start button and type services.msc then press Enter.  Right click on ASCII Vx Translator Service and select Stop. Navigate to C:\Program Files (x86)\Pelco\ASCIIVxTranslatorService\ and remove default from the below xml's as needed. Generally ASCIIEventServerSettings.xml will be the only one. Run Notepad as Administrator or use Notepad++.

  1. defaultAlarmConfiguration.xml
  2. defaultASCIICommandConfiguration.xml
  3. ASCIIEventServerSettings.xml
  4. defaultASCIIScripts.xml
  5. defaultCustomSituations.xml
  6. defaultMonitorToCellMap.xml

 

  1. Edit the ASCIIEventServerSettings.xml file (If using notepad, you will need to run Notepad as Administrator)
    • This file includes the VideoXpert login credentials. In the file below the default username admin and password Pel2899100 are Base64 encoded.  See https://www.base64encode.org/  This file also includes the default serial port settings for the ASCII communication. The serial port settings need to be adjusted here if the 3rd party ASCII interface settings do not match the default settings. Provide the settings for the below.
      • VxCoreAddress: IP address of Core or VIP if in a dual Core environment (i.e. 10.221.88.63)
      • VxCorePort: (i.e. 443)
      • VxUsername: (i.e. YWRtaW4=)
      • VxPassword: (i.e. UGVsMjg5OTEwMA==)
      • EthernetSettings:
        • Address: (i.e. IP Address of the PC where the ASCIIVxTranslatorService is installed on)
        • Port: (i.e. 9999)
        • ConnectionType: (i.e. UDP or TCP)
      • Serial port settings are COM1, 19200, None, 8 bits, 1 stop.
      • Save the file.


         
  2. Navigate to the Windows Start button and type services.msc then press Enter.  Right click on ASCII Vx Translator Service and select Start.
  3. Login to Admin Portal and click the Devices tab. Next to Type select external. Click Load Matches. The ASCII Vx Translator Service should be displayed. Place a checkmark next to it then select Commission on the bottom right.

 

The ASCII debug console (located on the ASCII Server).

  • Navigate to the Windows Start button and type services.msc then press Enter.  Right click on ASCII Vx Translator Service and select Properties.  Stop the ASCIIVxTranslatorService
  • Edit the ASCIIEventServerSettings.xml file and adjust the debug level as needed.  0=Off, 1=Normal Debug, and 2=Verbose Debug messages. (Generally 1 is ok)
  • Open Windows Explorer and navigate to C:\Program Files (x86)\Pelco > double click on ASCIIVxTranslatorService.exe
  • The ASCII Debug Console will open and allow user input.
    • Type Status then press Enter to print current status.

 

Wiring the 
Connect a null modem cable from the PLC to the PC that is running the ASCII Translator Service.  Verify that the serial port settings match the ASCIIEventServerSettings.

ASCII Command Set 
The ASCII command set can be found in the ASCII Integration Service document.  This document is included in the download package from Pelco PDN or Partner's First page.