VideoXpert: Tech Alert - Dual core active failover with Accessory server updates to 1.12 suite should be completed in a specific order.

Issue

Failover services will not function with your VideoXpert 1.12 environment until you update your Accessory Server to version 1.3.

Product Line

Pelco Video Management

Environment

  • VideoXpert Suite 1.12 - Active Failover
  • Qty. 2 - VX CMG
  • Qty 1-2 - VX Accessory Server
     

Cause

Major mongo upgrades were included in both VideoXpert Core and Accessory Servers

Resolution

If your VideoXpert environment contains an Accessory Server, you must update your system in the following order to minimize downtime within your system.  Please refer to Lessons Learned Article LL#18771 "Updating Dual Core/CMG and Accessory Servers - Best Practices".  You can view it here
 
1. Update one of the VideoXpert Core Services
2. Update the Accessory Server 
3. Update the remaining VideoXpert Core Service
4. Update all of the VideoXpert Media Gateway Services 
 
The Accessory Server to version 1.3 is a requirement for full functionality within VideoXpert 1.12.  
 
Failover services will not function with your VideoXpert 1.12 environment until you update your Accessory Server to version 1.3.