VxPro: aggregation connection test fails

Issue

Vx Ultimate fails to connect to an aggregated VxPro system.

Product Line

Pelco Video Management

Environment

  • VxPro installer version 1.0.0.3226
  • Vx Ultimate 2.0.1.10

Cause

Aggregator password has not been set in VxPro.

Vx Core log will show the following message:
ERROR [2017-07-18 11:27:37.106] [dw-751 - POST /system/members/v4.5/validate] com.pelco.vms.webService.business.requesthandlers.system.SystemRequestManager: Failed retrieving Serenity System from remote site https://172.30.108.219:443/system due to server application response error

Resolution

1. Log into the VxPro system

2. Launch Toolbox.

3. Click the Users tab.

4. Edit the aggregator account.

5.  Set a password. 

6. Open the Admin Portal for the Ultimate system

7. Navigate to Config >> Aggregation >> Add system

8. Add the VxPro system information and use the newly created aggregator password.

9. The connection test should be successful