Digital Sentry: Email notification based on an event trigger (System Messages, Video Loss, Motion, Analytics, Alarm, ASCII).

Issue

  • How to configure Digital Sentry to send an email when a camera goes offline (Video Loss)?
  • Have an email sent when motion is detected by a camera.
  • Email notification when a system error occurs.

Product Line

Pelco Video Management

Environment

  • Digital Sentry
  • DSSRV / DSSRV2
  • DS NVs
  • DS Admin - Zone Alarm
  • Email Notification

Cause

Process to configure.

Resolution

Digital Sentry supports sending an email using an SMTP server based on the following events:

  • System Messages - Informational, Warning and Errors
  • Physical alarm inputs (ENC5516).
  • Motion Detection
  • Video Loss
  • Serial Input
  • Sarix IP camera analytics

     

Configure the email server settings

(and enable System Messages - Informational, Warning and Error)

 

  1. Launch  DS Admin (START > All Programs > Pelco)
     
  2. Login with the 'admin' user account or another account which has administrative access.
     
  3. Click on the Email Notification folder.



     
  4. Enter the required server communication settings.

    • In the SMTP Server field, enter the email server used to send the email message.  This must be a valid SMTP server accessible from the DS server.
       
    • In the "Email sent from domain name" field, enter the domain name as configured on the SMTP server.
       
    • If required, enter a User Name and Password for sending email using the SMTP server.
       
    • Click Add Email Account. Enter an email address and select one or more message types. Click Save



      The e-mail account receives only those system messages that match the selected messages types.
       
    • Repeat the previous step for up to 75 email addresses.
       
  5. If you need to change message types sent to an email address, select the address and click Edit Email Account. Select the appropriate system message types and click Save.
     
  6. To delete an entered email address, select the address and click the Delete Email Account button.
     
  7. To test a configured email address, select and address and click Test Email Account.  Check the email account to ensure that an email was sent.

    Note: The SMTP server selected for email notification of messages is automatically the same server selected for email notification of alarms, video loss, motion....etc using DS Admin > Zones.



 

Configure a Zone to send an email based on an event.  Events can be contact alarms, video loss, analytic, motion...etc
 

The instructions below are for creating an email notification based on a camera Video Loss event, the same instructions will work for Alarms, Analytics, Serial (ASCII) and Motion. Add the camera to the "Assigned" list under the desired event type tab to enable.

  1. In DS Admin, expand the VAU(s) folder and click on the Zones folder (last folder listed).
     
  2. Right-click Zones and select Add Zone



     
  3. The Add Zone options will be displayed.

    • Zone Name - Name the zone (Listed in the subject line of the email sent)
    • Zone Description - Description of the Zone (Will be in the body of the email sent along with the camera name)
    • Active -  Enable / Disable the zone.
    • Report Alarm - This was used with a pre DS ControlPoint client, no longer used.  Recommend just leaving enabled.
    • Record Until Reset Received - Changes the beginning of the post-alarm recording period. If you select this option, post-alarm
      recording does not begin until the alarm is reset to its normal state. Otherwise, the post-alarm recording period begins when the alarm
      is triggered.
    • Priority - Also no longer used.

       
    • Alarm Time in Seconds
      • Pre-alarm: Indicates how much of the video captured before the alarm occurs is inserted at the beginning of a video segment of an
        alarm event within this zone.
      • Post-alarm: Indicates how much of the video captured after the alarm occurs is appended to the end of a video segment of an alarm
        event within this zone.
      • Re-alarm: Indicates how long after an alarm occurs that ensuing alarms are ignored. For example, if you enter 5 seconds, alarms that
        are active less than 5 seconds after an initial alarm event do not trigger recording.

        NOTE: When creating a zone for the recording of video loss events, be sure to include an additional three seconds to account for the maximum
        lag between the loss of video and the triggering of the alarm. (The system monitors for video loss every 1.5 seconds.) For example, if you want to
        record 5 seconds of pre-alarm video on the zone, set the pre-alarm time to 8 seconds.
         
  4. After you enter this information, click Save to add the zone to the Zones directory in the directory tree.
     
  5. Select the newly created zone listed under the Zones folder.


     
  6. Select the Cameras tab after the Zone loads. 

    !!When configuring cameras for video loss notification, do not add all cameras to a single zone.  It is recommended to create an individual 'Zone' for each camera.  So only one camera should be listed in the Cameras tab assigned window as well as in the Video Loss tab assigned window.



     
  7. Select the camera which will be listed in the email or have video recorded if when a trigger is received, click Add.  The camera will move to the Assigned list.
     
  8. Select the Video Loss tab.


     
  9. Select the camera that will trigger the event associated with the tab selected, for Video Loss generally this will be the same camera selected in the Cameras tab. 
    Click Add.  The camera will move to the Assigned list.
     
  10. Select the Schedule tab.


     
  11. Use the Fast storage rate, the Alarm Boost feature was a feature connected to older OBS DS capture cards, these are no longer used as well as the alarm boost feature itself.

    To remove time from the schedule, click the gray square next to Clear (or the Clear Schedule button), then 'left-click + hold' and drag to remove blue color and replace with gray.  To add color, click the blue square next to Fast and 'left-click + hold' drag (or click Full Week Fast button).
    The color listed in the Schedule represents the active time for the alarm, if color is removed, the gray areas indicate time the alarm/zone is not active and will not trigger.
     
  12. Select the Email Configuration tab. Verify the mail server settings you added in the earlier step is listed.


    1. Click the Add Email Account button.
    2. Click the Add button under 'Email Accounts'.
    3. Enter the email address which should receive the video loss event emails.
    4. Click Save.
    5. In the Cameras to Include in the Email section, select the camera under Cameras in this Zone and click the arrow    to add. 
      The camera should move to the Cameras included in the email list.
    6. There is also an option to include a snapshot (jpeg) image with the event, enable if desired.



      Note: If the option to enable the snapshot is not shown, Save the email account, then select the new account in the list and click the Edit Email Account button, the option should now be listed.
       
    7. When finished click Save Account.
       
    8. Now click Save for the Zone itself, this will save all changes made to any tab within the zone.




      Example email notification:


       

Configure the MaxAlarmDuration

(Limits the amount of time an alarm event is recorded, if not reset by an alarm panel.  This setting determines how long video will record continuously during an active Zone trigger)
- The MaxAlarmDuration setting is most usefull when using a Zone to trigger alarm recording for a long period of time, something like an intervew room.
- Default setting is 20 minutes.

 

  1. Navigate to DS Admin > Configuration Parameters folder.
     
  2. Select Services - MaxAlarmDuration.
     
  3. Under Value enter the time desired in seconds. eg. 1 hour = 3,600 seconds.



     
  4. Click Save