Receive a connection error when attempting to login to Security Expert.

Issue

When attempting to log in the below network error, or similar, is displayed.

Connect: The server was unable to process the request due to an internal error.

Could not log on to Server. Please check your remote connection setup.

 

 

Further checking the Windows Application Event logs on the Server you may also find error messages similar to the below being logged against the Security Expert services.

CDTNames::GetTagName : Cannot open database "SecurityExpert" requested by the login. The login failed.

Product Line

SmartStruxure Solution, Other

Environment

Security Expert

MS SQL

Cause

The Security Expert services do not have the correct credentials to access the SecurityExpert database.

Resolution

1. Confirm the user account that the Security Expert services are using in Windows. Go to Start > Run > and type "Services.msc". Confirm the account that those services are being run under. By default, and in the example, this is the Local System account.

 

2. Run Microsoft SQL Server Management Sudio and under your server browse to Security > Logins. Find the user account that your services were using in step 1 and go to the Server Roles page of this user account. Enable the "sysadmin" server role, save changes and restart the Security Expert services.