How to sign up and login to Pelco Service and Support Portal

Issue

Pelco Partners and End Users need to register or login to to Pelco Service and Support Portal

Product Line

Pelco Video Management

Environment

  • Pelco Partners and End Users
  • Pelco Employees

Cause

Beginning July 16th, 2018, escalation from Basic Support to our North America Advanced Technical Support team for Endura and Digital Sentry cases will require a valid support entitlement.  Please login to the support portal and register your product today for a complimentary two incident support entitlement

Resolution

Related Lessons Learned Article:  "Professional Services:  Registering your Endura SM5200 or Digital Sentry DSSRV2 Server" LL#19894

Getting Started

To Sign Up:

  1. Click here to access the Pelco Service and Support Portal.  
  2. Click on Sign Up

     
  3. Enter your contact information then click on Submit


     

To Login:

  1. Click here to access the Pelco Service and Support Portal.  
  2. Enter your username and password then click on Log In