VideoXpert: v2.1 - v2.5 Core database restore using a system backup (Applies to both Single Core and Multi-Core systems)

NOTICE

POTENTIAL FOR DATA LOSS.
The steps detailed in the resolution of this article may result in a loss of critical data if not performed properly. Before beginning these steps, make sure all important data is backed up in the event of data loss. If you are unsure, please contact Product Support Services prior to attempting the procedure below.

NOTICE

COMPLEX PROCEDURE REQUIRED.
The resolution of this article has many complex steps that may result in unforeseen results if not performed correctly. If you are at all unfamiliar with the requirements, please contact Product Support Services for assistance.

Issue

The VideoXpert Core database has been corrupted and you want to restore the core(s) using a recent system backup.

Product Line

Pelco Video Management

Environment

VideoXpert v2.1

VideoXpert v2.2

VideoXpert v2.5

Cause

The VideoXpert Core database has been corrupted and you want to restore the core(s) using a recent system backup.

Resolution

*NOTE: You must have a known good system backup before you begin and you must know what version of software was running on your Core(s) at the time the system backup was created as that is the version of software that needs to be installed back on the Core(s) before the backup is used to restore the database.

 

1) Log into Windows Server 2012 on the Core you want to restore (default username: "pelco", default password: "Pel2899100").

 

2) Right-click on the Windows button and select "Programs and Features" as shown below

 

 

3) Click on "VideoXpert Core" to select it and then click on "Uninstall" to uninstall the program as shown below

 

 

4) Click on "Videoxpert Media Gateway" and then click on "Uninstall" to uninstall that program as well.

 

5) Next, delete the  "C:\ProgramData\Pelco" folder (you must enable view hidden files to see this folder) as shown below

 

 

6) Next, delete the "C:\Program Files\Pelco" folder as shown below

 

 

7) If you configured your VideoXpert system to store the eventsDB on the D: drive, then you will want to delete that folder as well.

*NOTE: In the example below, the events database is located on on the D: drive in the "db" folder, so this folder needs to be deleted also.

 

 

*NOTE: If you are restoring a multi-core system, then stop here and repeat steps 1 thru 7 on the other Core(s) before continuing.

 

We are now ready to begin the reinstall procedure:

 

8) Install the VideoXpert Core software.
*NOTE: You need to install the same version of Core software on your Core as the version that was running when the system backup was created.

 

9) Install the VideoXpert Media Gateway software.
*NOTE: You need to install the same version of Media Gateway software on your Core as the version that was running when the system backup was created.

 

*NOTE: Do not configure the system at this point, just install the core and media gateway software only.

 

10) Copy the system backup that you want to restore from to the core that you are trying to restore.

 

11) Right-click on the Windows button and select "Command Prompt (Admin)" as shown below

 

 

12) Type in the path to the restore utility, the switch backup, and the path to the system backup using this format:

"c:\program files\pelco\core\tools\restoreUtil.bat" -–backup

*NOTE: "In the example below, my system backup is located at 'C:\Users\pelco\Desktop\corebacup-2018-08-03T16-19-18z', so the full command that
I need to type to start the restore is:

"C:\Program Files\Pelco\Core\tools\restoreUtil.bat" --backup C:\Users\pelco\Desktop\corebacup-2018-08-03T16-19-18z

 

"c:\program files\pelco\core\tools\restoreUtil.bat" -–backup

 

13) Once the process finishes, you will see the  "*** SUCCESS ***" in the last line of the output as shown below:

 

 

*NOTE: If you have a multi-core system, then you need to repeat steps 8 thru 13 for each remaining core.

14) Once all the Cores have been restored, go to the Devices tab in the Admin Portal for your newly restored Core,
and remove, and then re-discover all Media Gateway(s).

*NOTE: Failing to remove and re-discover Media Gateways may prevent video streaming in the newly-restored VideoXpert environment.
 

15) Verify that you can now use the system and stream video in Ops Center as the restore process is now complete.