Issue
Error: "Error: Device does not refer to a COM port" when trying to download an application to a Xenta controller.
Environment
- Vista Workstation
- LNS Network
Cause
This message is generated when the LonWorks network in the Vista database does not have a COM port (LNS port) defined. The problem occurs when Vista database has been "updated" with a second LNS database and is added to an existing database creates two LNS databases with only one communication port. The communication port in the Vista database can only be associated with a single LNS database. If trying to communicate to the first LNS database there will not be a communication port to use.
Resolution
- Remove all objects added to the Vista database from the second LNS database
- Edit the properties for your existing LonWorks network.
- Browse the LNS port back into the "LTA Port" field.
- Using Vista Server Setup, create a new Vista database directory. Utilize the new database for your second LNS database.
Note: Use a unique LNS database with each Vista database. Projects with multiple LNS databases must have a LTA, iLon, or L-IP configured for each LNS database.