Issue
The Vykon Alarm Client will not connect to the Niagara R2 Enterprise Server station.
Environment
- Vykon Alarm Client
- Niagara R2 Enterprise Server station
Cause
The Vykon Alarm Client uses TCP port 4321 to communicate with the Enterprise Server. Many firewall, antivirus, and Internet security applications (e.g. Windows Firewall, antivirus & remote access software) block TCP port 4321 by default.
Resolution
Either disable the offending application, or create an exception policy in the application to open TCP port 4321.
To view active TCP connections, open a DOS window, and type: netstat -ano.
The output will look something like this:
Active Connections Proto Local Address Foreign Address State PID
TCP 0.0.0.0:13 0.0.0.0:0 LISTENING 956
TCP 0.0.0.0:37 0.0.0.0:0 LISTENING 956
TCP 0.0.0.0:135 0.0.0.0:0 LISTENING 1368
TCP 0.0.0.0:445 0.0.0.0:0 LISTENING 4
TCP 0.0.0.0:3011 0.0.0.0:0 LISTENING 756
TCP 0.0.0.0:6523 0.0.0.0:0 LISTENING 3752
TCP 0.0.0.0:27700 0.0.0.0:0 LISTENING 748
TCP 10.1.146.152:139 0.0.0.0:0 LISTENING 4
TCP 10.1.146.152:2531 72.247.127.34:80 CLOSE_WAIT 3616
TCP 10.1.146.152:2532 72.5.124.55:80 CLOSE_WAIT 3560
TCP 10.1.146.152:2533 72.247.127.11:80 CLOSE_WAIT 3560
TCP 10.1.146.152:4245 10.1.146.32:4321 ESTABLISHED 216
A successful connection to the Enterprise Server will have an entry similar to the last line, where the Foreign Address (e.g. 10.1.146.32:4321) will have a state of ESTABLISHED.