Issue
What information is required in requesting an RMA for any model of Niagara R2 UNC / Niagara G3 ENC?
Environment
- Niagara R2 UNC
- Niagara G3 ENC
Cause
Return a defected product to service.
Resolution
The Serial Number and Symptom (Description of Issue) are required. If advance replacement equipment is required, or if the unit is out of warranty, a purchase order number will also be required. Call and provide this information to Product Support Services at 1-888-444-1311, Note, there may be additional information required to aid in resolving the difficulty.