Issue
Local security policy may prevent Niagara R2 Workplace Pro from running properly.
Environment
Niagara R2 Workplace Pro
Cause
The Local Security Policy settings and blocking port 3011 might prevent the WorkPlace Pro from accessing the local computer (Localhost).
Resolution
Workplace Pro's "Admin Tool" software requires network access to the local computer (Localhost) to allow it to connect to a station. The typical cause is Firewall software or other security software on the computer blocking access to port 3011.
If the port in the internal firewall has been opened and "Admin Tool" still cannot run, local security policy may be preventing access to the computer. To verify the local security policy settings, open the "Local Security Policy" function, found under "Administrative Tools" in the Windows Control Panel. Within the "User Rights Assignment" under the "Local Policies", there are two rights that must be configured properly.
The first of these two policies is "Access this computer from the network". In the "Security Setting" for this policy, the "Administrators" group must be present.
The second of these two policies is "Deny access to this computer from the network". The exclusions in this policy are a bit more complex to configure and requires an understanding of the group membership of the user attempting to run Workplace Pro. To configure this setting, the user's name must not be listed and any security group to which the user belongs must not be listed in the "Security Setting" list. With typical user security settings, the user's name and the "Administrators" group must not appear in the "Security Setting" list.
After making changes to the Local Security Policy, the user must log off and log back into the computer to force these policies to be activated.