Issue
Procedure for correcting duplicate LON device node numbers in a Niagara R2 UNC station
Environment
Niagara R2 UNC station
Cause
Occasionally, when a LON device has been removed from use at one site and installed at another site, the previously configured LON subnet and node number can be the same as an existing device in the new installation. The problem typically manifests itself when attempting to learn and commission the new controller using the Workplace Pro.
Resolution
Use the following steps to correct the problem.
- Open the "Lon Device Manager" from the right-click menu of the LonWorks Service.
- Click "Find" to get a list of all the LON controllers under the UNC. An error message will be displayed indicating that a device with a duplicated subnet and node number has been detected.
- Right-click on one of the devices that has the duplicate address. If no right-click menu is displayed, right-click on a different device with the same subnet and node number.
- From the right-click menu, select "Properties" then select the "General" tab then select the "Engineering" tab.
- In the "Node State" pulldown list, select "Unknown".
- Change the node number, displayed in the "NodeID" box, to a value that is not currently used.
- Click the "Apply" button to save the changes.
- Click the "back-arrow" button to return to the Device List screen.
- Reselect the device just changed then click the "Commission" button. In the pop-up window that is displayed, verify that the Neuron ID of the device is correct then click the "Apply" button. Wait for the commissioning process to complete.
- 10. If additional devices are shown with duplicated node addresses, repeat steps 3 through 9 for each additional pair of duplicate addresses.