Issue
Echelon now has an easier way to check the status of your LonMaker License. Determine the status of your credits in seconds.
Product Line
TAC Vista
Environment
- LonMaker 3.1
- LonMaker 3.2 (Turbo)
- LNS
Cause
Determine corrupted credits/licensing issues without the old method of using the command prompt. This will do the same thing with a click of a button.
Resolution
The tool will diagnose the license status and give you the solution you need to follow to fix the problem.
- Download here: Echelon License Diagnostic Utility
- Save or run
- Choose LonMaker credits
- Copy to clipboard and email to Echelon if corrupted credits are shown.
Screen shot of invalid LonMaker license:
This error occurs if the license file you specified is not located in the application directory. To resolve this, you will need to reboot your PC and log in as a user with Administrative privilege. Next, make sure the files listed below are located in the C:\Windows\LNS Licenses folder.
Note that the "LNS Licenses" folder is a hidden one; therefore, in Windows Explorer, go to Tools - Folder Options..., and in the View tab, select "Show hidden files and folders." Now uncheck the "Hide protected operating system files (Recommended)" option.