Issue
What does the ReassertDaemon error in a Niagara R2 UNC Standard Output Window mean?
Environment
Niagara R2
Cause
The UNC station is unable to log into the Enterprise Server station as a client to update the slave schedule information.
Resolution
ERROR: ReassertDaemon [SubscriptionModule] java.lang.NullPointerException
- at tridium.foundation.node.Node.set (bytecode 5)
- at tridium.foundation.node.ExecutableNode.setViaSubscription (bytecode 33)
- at tridium.foundation.prism.Subscription.updateValue (bytecode 10)
- at tridium.foundation.prism.Subscription.reassert (bytecode 106)
- at tridium.foundation.prism.SubscriptionsTable.reassert (bytecode 18)
- at tridium.foundation.prism.SubscriptionModule$ReassertDaemon.run (bytecode 79)
The UNC is unable to subscribe to the server and continues to retry. Eventually, a message indicates too many pending connections. The usual suspect are the firewalls (Windows, anti-virus software, etc.) blocking connections into the Enterprise Server. The server will be able to connect to the UNC but the UNC will not be able to connect into the server. The Enterprise Server needs to have its Address Book updated to include all the UNC’s IP Addresses, Usernames and Passwords.