Issue
When using a Niagara R2 Enterprise Server with a "Remote Printer Recipient" on a large network with many printers, the Enterprise Server can take several minutes to complete its station startup following a reset.
Environment
- Niagara R2 Enterprise Server
- Network printers
Cause
This situation is possible due to the remote printer recipient object that is attempting to populate its network printer recipient list. This would not be noticeable unless there are hundreds of printers on the network. This is how the remote printer recipient is designed to function.
Resolution
Possible workarounds for very large jobs affected by this would be to:
- Re-configure the customer's network so there are not so many networked printers
- Define local printers (or map network printers as local printers) in order to use the Local Printer Recipient
- Use the Vykon Alarm client to send alarms to network printers. Be advised printers other than dot matrix types will print one alarm per page.