When trying to install Niagara R2 version 2.301.330, the process halts and reports that Java Virtual Machine (JVM) is not installed. What version of JVM is required?

Issue

When trying to install Niagara R2 version 2.301.330, the process halts and reports that Java Virtual Machine (JVM) is not installed. What version of JVM is required?

Product Line

TAC I/A Series

Environment

Niagara R2 version 2.301.330

Cause

All Niagara R2 versions prior to 2.301.514 require Microsoft's Java Virtual Machine.

Resolution

All revisions of Niagara R2 prior to 2.301.514 require Microsoft's JVM. To confirm if it is installed, open a Command Prompt window and type "jview" then press Enter. This command will display the current version of Microsoft's JVM (or that it is not installed).

Download and install Java_Virtual_Machine_for_WinXP.exe.

All revisions of Niagara R2 starting with 2.301.514 and beyond require Sun's JVM. To confirm if it is installed, open a Command Prompt window and type "java -version" then press Enter. Visit http://www.java.com regularly to keep the JVM updated. The Microsoft and Sun JVMs can co-exist on the same Niagara host computer.