Issue
On a Niagara R2 computer, the following error appears (in the Niagara Console) when trying to run Workplace Pro:
*** Unjar: c:\niagara\r2.301.522\nre\modules\demo.unjar
Extract: c:\niagara\r2.301.522\nre\modules\demo.unjar
java.util.zip.ZipException.
Environment
Niagara R2 computer
Cause
.unjar files in the listed directory on the computer.
Resolution
The .unjar files are used by the Niagara installer during installation and have somehow been copied into the listed directory on the computer. Stop the Niagara Service on the computer, delete all .unjar files in the listed directory, then re-start the Niagara Service. Workplace Pro will now function.