Issue
CAUTION : Do not enable Authentication in a Niagara R2 station's Lonworks service when MNL controllers are on the LON trunk under a UNC. Doing so can disable LON communications to the MNL controller, possibly permanently.
Environment
- Niagara R2
- MNL Controllers
Cause
Enabling Authentication in a Niagara R2 Lonworks service, when MNL controllers are on the LON trunk under an R2 UNC, can put the controllers into one of two modes that make them unable to communicate with Workplace Tech, the UNC, or any other LON device.
Resolution
Enable Authentication is a Lonworks Service Command, as is Disable Authentication. A prompt will appear to confirm the command before it will be applied; a pop-up box will appear with the prompt “Are you sure you wish to invoke the enAuth command?” Click “NO” to cancel the command.
The two modes are described as follows:
In the first mode, which results if the user has enabled Authentication, but not commissioned the controllers with Authentication enabled, it might be possible to recover the controller. Use the service pin method to clear the controller authentication (domain tables); see WorkPlace Tech Tool 4.0 Engineering Guide, p. 602, Service Pin Operation (F-27254). The controller will be in an unconfigured state that still allows NodeUtil to access and change the memory. Contact a Product Support Services for instructions on using NodeUtil to attempt recovering the controller.
In the second mode, the controller authentication (domain tables) have been cleared by using the service pin method, and then the user has attempted to commission the controller with the network management tool. The result is that the controller will permanently be in a “hard offline” condition, and will not be recoverable.