Which antivirus software is compatible with Niagara R2 and G3?

Issue

Which antivirus software is compatible with Niagara R2 and G3?

Product Line

TAC I/A Series

Environment

Niagara R2 Workplace Pro (all versions), Niagara G3 Workbench (all versions)

Cause

Antivirus software can block ports and services used by Niagara R2 and G3

Resolution

By default, Niagara R2 software needs the following ports/services/applications "open", or unblocked:

  • Port 80 (station communications & Web access)
  • Port 3011 (Admin Tool)
  • Niagara Service (Control Panel > Administrative Tools > Services)
  • Files in the C:\ < niagara r2 release number > \nre\bin directory

By default, Niagara G3 software needs the following ports/services/applications "open", or unblocked:

  • Port 80 (Web access)
  • Port 1911 (station communications)
  • Port 3011 (Platform access)
  • Niagara Service (Control Panel > Administrative Tools > Services)
  • Files in the C:\ < niagara g3 release number > \bin directory

Various antivirus software products by default will block one or more of the above, and need to be configured to allow or "unblock" them.  Niagara R2 and G3 software will work with any antivirus program that allows unblocked communication to the above ports, services, and files.

  NOTE: The specified ethernet ports must be open bidirectionally for both TCP and UDP traffic.