Issue
Vista Server - "Comm port not configured" error message
Environment
- Vista Workstation
- LonMaker
Cause
While reviewing the EMS if mouse over a point you get a "comm port not configured" error message and points appear offline. This isn't a Vista Server issue however its an LNS issue resulting in the lonmaker protocol not working correctly.
Resolution
- Open LonMaker
- You should receive a "recovery - global" error message.
- Close LonMaker
-
Proceed to the following path on the clients computer.
C:\Lm\Db\projectname\recovery - Find the "objects.dat" file. This file should disappear when Vista and LonMaker aren't running.
- Shutdown Vista Server and LonMaker and see if the file disappears.
- If it doesn't then this file has been corrupted and needs to be deleted.
- Once you delete the file open LonMaker and verify the error message is gone.
- Once verified, start Vista Server and check communication and the "comm port not configured error message should be gone as well.