Can not change password for TAC Vista user from TAC Webstation with language pack conflict

Issue

After changing password of a user in webstation it is not possible to log in with the new password. This happens on machines were the TAC Vista server in installed, without language pack, on a server that have different regional settings than the operating system language.

Product Line

TAC Vista

Environment

Windows with regional settings set to another than the OS language.

TAC Vista installed without language pack

Cause

There is a mismatch between localization settings for Tacos server, Webstation and the regional settings on the Windows system.

Resolution

Make sure you are using the same language pack for Vista as the regional settings on the host are set.

If you are using a webserver and change the password via a webstation you can also workaround this issue by changing the language code in the “C:\Inetpub\wwwroot\TACVistaWeb514\web.config”. Look for the entry  

The example above uses English settings. Change this to desired localized setting. For instance the culture code for Poland is pl-PL (language-country) and sv-SE for Sweden.

Note: It is always recommended to use the correct language pack before changing the localization code by hand in the config file. Having a mismatch between the installed language pack (or manually changed culture code) and regional settings might cause problems with incorrect formats (e.g., for dates, times, decimal character, character sets, etc.).