Issue
These errors are internal to Echelon LonMaker and require the assistance of Echelon Technical Support.
Environment
LNS
LonMaker
Vista
NL220
1-800-258-4LON or 1-800-258-4566
Cause
NS #9 lcaErrNsBadClient
NS #11 lcaErrNsNoClient
NS #14 lcaErrNsClientBlocked
NS #16 lcaErrNsNotImplemented
NS #18 lcaErrNsServiceFailure
NS #20 lcaErrNsPrematureRelease
NS #21 lcaErrNsRootBus
NS #22 lcaErrNsRootDoesNotExist
NS #23 lcaErrNsNoFreeRootTransactions
NS #30 lcaErrNsEventFailure
NS #32 lcaErrNsSubscriptionDblimit
NS #34 lcaErrNsSegmentation
NS #41 lcaErrNsDbError
NS #42 lcaErrNsOutOfJournal
NS #46 lcaErrNsNetworkHasInstalledNodes
NS #49 lcaErrNsIntegrityError
NS #55 lcaErrNsProgramDblimit
NS #57 lcaErrNsNvmtDbLimit
NS #61 lcaErrNsMsgError
NS #62 lcaErrNsCancelError
NS #71 lcaErrNsTimerRange
NS #83 lcaErrNsObjectLocked
NS #84 lcaErrNsInvalidContext
NS #85 lcaErrNsServerNotFound
NS #109 lcaErrNsStaleFileHandle
NS #115 lcaErrNsManagerNotAllowed
NS #126 lcaErrNsUnimplementedCategory
NS #127 lcaErrNsUnimplementedProperty
NS #128 lcaErrNsDisallowedInMipMode
NS #129 lcaErrNsDisallowedInTxHandler
NS #130 lcaErrNsNssNotInitialized
NS #146 lcaErrNsInvalidErrorContext
NS #151 lcaErrNsBatchOptionNotImplemented
NS #152 lcaErrNsBatchNoResult
NS #172 lcaErrNsEngineNotInitialized
NS #189 lcaErrNs16BitUserErrorCode
NS #190 lcaErrNs16BitWarningCode
NS #191 lcaErrNs16BitErrorCode
NS #289 lcaErrNsEngineIsSuspended
NS #290 lcaErrNsNotSupportedFromRemoteClient
NS #4031 lcaErrNsUpdateFuncError
NI #24 lcaErrNiObsolete
NI #27 lcaErrNiUnimplemented
LNS #5 lcaErrUninitializedDb
LNS #35 lcaErrGeneric
LNS #36 lcaErrDbServer
LNS #39 lcaErrWrongWriteDataSize
LNS #40 lcaErrInvalidFormat
LNS #54 lcaErrCantCopyLNSDirectory
LNS #70 lcaErrCantRecoverReadOnlyFile
LNS #71 lcaErrStringIsEmpty
LNS #73 lcaErrInvalidProgramType
LNS #97 lcaErrInvalidRmcObject
LNS #98 lcaErrInvalidRmcServer
LNS #99 lcaErrInvalidRmcClient
LNS #101 lcaErrInvalidRmcMethod
LNS #123 lcaErrInvalidPropChangeEvent
LNS #133 lcaErrInternalErrBadExceptionCode
LNS #134 lcaErrInternalErrBadHresultExceptionCode
LNS #135 lcaErrInternalErrBadVNIDataServer
LNS #136 lcaErrInternalErrBadNsdHandle
LNS #137 lcaErrInternalErrStartTransaction
DS #365 lcaErrLnsDsUnexpected
DS #366 lcaErrLnsDsFailed
Resolution
These are internal errors and should be reported to Echelon's customer support. Contact Echelon at 1-800-258-4LON (258-4566) or LonSupport@Echelon.com.