Error: LNS #15 lcaErrInvalidCollectionIndex Invalid OLE collection index(Subsystem: LNS, #15)

Issue

A query to an LNS collection object has been made using an invalid index number. The range of valid indices starts with 1 and ends with the current item count.

Product Line

TAC Vista

Environment

LonMaker
NL220
Vista
LNS

Cause

When launching the plug-in of a device.

Resolution

  1. In NL220, go to the "Plug-Ins" menu dropdown
  2. If the option exists, Verify that the option "Simple string command" is deactivated.
  3. If not, uncheck it and try to relaunch the plug-in.

*Note this option has been removed in more current versions of NL220, there may not be an option represented.