Error: NI #31 lcaErrNiStateError

Issue

The LonMaker tool has the incorrect NSI or "VNI" NI application images

Product Line

TAC Vista

Environment

LNS
NL220
LonMaker
Vista

Cause

The LonMaker tool only works with NSI or "VNI" NI application images, i.e., PCL10VNI or NSIPCLTA.

Resolution

Unable to change the state of the network interface.

i.LON 100 or SmartServer:

There are two types of RNIs, "Other" and "LonScanner". For LonMaker (or a LNS application), you must use the "Other" RNI. For LonScanner, you must use the "LonScanner" RNI. Check the interface setting in the LonWorks Interface Applet which is available in the Windows Control Panel. Select the RNI tab and double click the RNI you are using. If the interface setting is set incorrectly, change it to the correct one and press the Apply button.

PCC-10 or PCLTAs:

The LonMaker tool works with NSI or "VNI" NI application images, i.e., PCL10VNI or NSIPCLTA. To eliminate this error message, open the LonWorks Plug 'n Play utility from the Control Panel and check your NI Application. If it is "PCC10L7", it needs to be changed to PCL10VNI or NSIPCLTA. Hit Apply to change the image, then go ahead and open the network again.