80010105 Error when downloading through System Plug-In

Issue

 System Plug-In returns "Error: 80010105" when downloading a programmable controller.

Product Line

TAC Vista

Environment

Vista Server

NL220 / Lonmaker

System Plug-In

Cause

The cause is unknown at this time.  When downloading a controller through System Plug-in this error will stop the download from proceeding.  It seems to be system-wide once it happens, not controller related.

Resolution

  1. Go to Start > Settings > Control Panel > Add or Remove Programs
  2. Uninstall the TAC Toolpack
  3. Re-Install TAC Toolpack (make sure it matches the Vista Server version).