Unable to Create a backup in DBCreate.

Issue

Unable to create a backup of an I/NET Seven Database using DBCreate, gets a backup failed error.

Product Line

TAC I/NET

Environment

Windows XP, Windows Vista OS, with SQL 2000, 2003 and 2005.

Cause

Functionality of the host pc and the database seems to be inconsistent.

Resolution

Option 1:

  1. Stop all of the SQL Services (SQL Server, SQL Agent, SQL Distributed Coordinator)
  2. Copy INetDb.mdf and INetDb_log.ldf to an alternate locations (located in C:\Program Files\Microsoft SQL Server\MSSQL.1\MSSQL\Data)
  3. Restart all SQL Services.
  4. Launch DBCreate and remove the existing I/NET Seven Database.
  5. Create a new I/NET Seven Database.
  6. Stop all of the SQL Services (SQL Server, SQL Agent, SQL Distributed Coordinator)
  7. Copy the saved INetDb.mdf and INetDb_log.ldf over the newly created files.
  8. Restart all SQL Services.
  9. Launch DBCreate and attempt a backup.

Option 2 (If Option 1 does not work)

  1. Stop all of the SQL Services (SQL Server, SQL Agent, SQL Distributed Coordinator)
  2. Copy INetDb.mdf and INetDb_log.ldf to an alternate locations (located in C:\Program Files\Microsoft SQL Server\MSSQL.1\MSSQL\Data)
  3. Uninstall and Reinstall I/NET Seven.
  4. Stop all of the SQL Services (SQL Server, SQL Agent, SQL Distributed Coordinator)
  5. Copy the saved INetDb.mdf and INetDb_log.ldf over the newly created files.
  6. Restart all SQL Services.
  7. Launch DBCreate and attempt a backup.

Refer to Lessons Learned Article LL#15834 for more issues about DBCreate.