Vista administrator user account (system manager) has no admin rights (cannot add/edit/delete any user, cannot change time schedules, graphics, etc).

Issue

The system manager user account is created; however, that account does not have administrator rights such as add/delete user accounts.

Product Line

TAC Vista

Environment

TAC Vista Workstation 5

Cause

When adding a system manager account in Vista, that account also needs to be added into the administrator group ($Administrators). If the system manager account is not listed under the administrator group, it will not be able to behave as the administrator.

Resolution

  1. Maker sure the user account is set as a “System manager”
    • Log into Workstation as an administrator and click on the root project folder in the left panel, right click on the user account in the right panel, and then select property.
    • Under “General/Authority level”, it should say “System manager”. If not, change to “System manager”.

                                 

      NOTE: If the textbox is grayed out, it means the current logged in account does not have the permission to make changes to that user account. Please read Lessons Learned Article #4393 to add the control rights.

      If Lessons Learned Article #4393 fails also, please go to step 2.
       
  2. Click on the root project folder in the left panel, and right click on the “$Administrators” in the right panel, then select “Properties”.
  3. Under “Users”, all administrators should be listed here. Make sure the desired user account name is listed. If not, use “Add” function to add the user account.
    • If the text box is grayed out, log in as one of the system manager account listed under “Users” to process this step.

                      

      NOTE: If all system managers listed under “Users” are no longer available. Please contact product support to unlock the database.