Issue
After modifying a BACnet Schedule it goes into Fault with its Reliability field showing "ConfigurationError".
Environment
Continuum, BACnet Schedule Object
Cause
When a user logs into Continuum with a User that does not have view rights to the InfinityController object, the schedule object used is the Infinity Schedule instead of the expected BACnet Schedule. The Infinity Schedule uses Active/Inactive for its TimeValue entries instead of the default 1/0 that the BACnet Schedule object uses. When a value is set as Active/Inactive, the Schedule is unable to interpret this value and goes into fault.
Resolution
- Make sure that any User that needs to modify BACnet Schedules has view rights to the InfinityController object enabled.
- Remove all TimeValue Entries that are Active/Inactive, replace with valid entries, save Schedule.