A Niagara R2 UNC station fails to open the lonworks driver and cannot start LON communications.

Issue

Communication to LON controllers is lost.  After a re-start of the station, the following errors appear in the standard output window:

---------- Station Starting:   MON MAY 02 14:53:10 2011 ----------
Tridium Niagara Station, r2.301.529.v1 [test]
MESSAGE: ErrorLogService installed [/test/services/ErrorLogService]
Start service: ControlEngineService [3] ControlEngineService
Start service: UiEngineService [7] UiEngineService
Start service: NotificationService [6] NotificationService
Start service: LogService [5] LogService
Start service: AuditLogService [2] AuditLogService
Start service: ErrorLogService [4] ErrorLogService
Start service: LonWorksService [9] LonWorksService
Error opening driver LON1 java.lang.Exception: Unable to open lonworks driver
***************************************************************
ERROR: Cannot startService [Sys: LonWorksService [9] LonWorksService]
java.lang.IllegalStateException: Unable to open lonworks driver
   at tridiumx.lonworks.services.LonLinkLayer.start (bytecode 143)
   at tridiumx.lonworks.services.LonWorksService.startService (bytecode 12)
   at tridium.foundation.Sys.startServices (bytecode 49)
   at tridium.foundation.Station.startStation (bytecode 63)
   at tridium.foundation.Sys.boot (bytecode 27)
   at tridium.foundation.Sys.bootLocalSns (bytecode 17)
   at tridium.tools.StationMain.bootSns (bytecode 0)
   at tridium.tools.StationMain.doIt (bytecode 352)
   at tridium.tools.StationMain.main (bytecode 10)
   at java.lang.reflect.Method.invoke (Native Method)
   at tridium.nre.Nre.mainImpl (bytecode 271)
   at tridium.nre.Nre.main (bytecode 1)
tridiumx.lonworks.LonException E_LON_COMM_SERVICE_NOT_STARTED
   at tridiumx.lonworks.services.LonCommService.doLonCommSendRequest (bytecode 19)
   at tridiumx.lonworks.services.LonCommService.lonCommSendRequest (bytecode 3)
   at tridiumx.lonworks.services.LonCommService.lonCommSendRequest (bytecode 68)
   at tridiumx.lonworks.util.Neuron.readMemory (bytecode 29)
   at tridiumx.lonworks.util.Neuron.readMemory (bytecode 9)
   at tridiumx.lonworks.util.Neuron.isNMAuthSet (bytecode 32)
   at tridiumx.lonworks.util.Neuron.isNMAuthSet (bytecode 16)
   at tridiumx.lonworks.devices.LocalLonAppDevice.verifyDevice (bytecode 2)
   at tridiumx.lonworks.services.LonWorksService.stationReady (bytecode 28)
   at tridium.foundation.Sys.stationReady (bytecode 23)
   at tridium.foundation.Station.startStation (bytecode 87)
   at tridium.foundation.Sys.boot (bytecode 27)
   at tridium.foundation.Sys.bootLocalSns (bytecode 17)
   at tridium.tools.StationMain.bootSns (bytecode 0)
   at tridium.tools.StationMain.doIt (bytecode 352)
   at tridium.tools.StationMain.main (bytecode 10)
   at java.lang.reflect.Method.invoke (Native Method)
   at tridium.nre.Nre.mainImpl (bytecode 271)
   at tridium.nre.Nre.main (bytecode 1)
MESSAGE: Station started successfully. (HTTP port=80) [test]

These errors follow a short time later:

Freeing transaction from transmit driver, tag is 4
The LonException code is java.lang.Exception: ldvWrite() failed - rc = 6, in transmit driver
Freeing transaction from transmit driver, tag is 5
The LonException code is java.lang.Exception: ldvWrite() failed - rc = 6, in transmit driver

 ... repeated

Product Line

TAC I/A Series

Environment

Niagara R2 UNC-520-2
Niagara R2 UNC-410-1
(including the -N international versions)

Also applies to obsolete models:  UNC-500, UNC-510, UNC-600, UNC-610

Cause

These errors indicate the Niagara operating system is not communicating to the (on-board) Echelon MIP chip. 

To confirm, run the following test:

  1. Open the running station in Tree View
  2. Go to the Properties of the localLonDevice, specifically the Engineering tab
  3. Blank out the "neuronId" and click Apply
  4. Reboot the UNC
  5. When the station has started successfully, return to the neuronId field and observe the value in the box

If the neuronId field is all zeros, then there is a hardware problem with the Echelon MIP chip.

Resolution

This issue is not field-repairable.

Contact Product Support Services for a return authorization number.