User Defined Units on I2V integration were accidentally set incorrectly

Issue

When importing I/NET sav files into an XBuilder project, it will try to reconcile unknown Engineering Units in I/NET with recognized units in XBuilder.  If these units are set incorrectly by accident, there is a process for correcting them.

Associate Unit
Please associate the unrecognized unit with a unit known to XBuilder. If you do not want an association for this unit, select "NoCategory", which will result in that all signals having this unit will be displayed as having no unit.

Product Line

TAC I/NET, TAC Vista

Environment

  • Xenta 527, 731, 913
  • I2V
  • I/NET sav files

Cause

Engineering unit Associate unit dialog accidentally set wrong units, or need to set a defined unit to "No Category" to avoid conversion issues in an integration.

Resolution

  1. Locate the XBuilder project directory
  2. In the root project directory is a filed called UserDefUnits.txt
  3. If there are not many units defined, this file can be deleted.  It will then be recreated in its entirety the next time a batch of sav files are added to the XBuilder project.
  4. If there are many definitions that need to be preserved, this file can be edited. Erroneous entries can be deleted, or edited if the correct XBuilder unit definitions are known.  Example file below:

    ; *** UserDefUnits.txt ***
    ; User defined conversion of units to TAC XBuilder/Domino units
    ;
    degF=F

     
  5. Browse the sav files into the project again.  This will prompt the user to define the unknown units again, and the correct selection can be made and stored in the UserDefUnits.txt file.