Issue
Unable to connect to a NetController I using a terminal emulator program such as hyperterminal.
Unable to access controller webpage using MS Internet Explorer.
Environment
- InfinityController
- Internet Explorer
- HyperTerminal
- Terminal Emulator
- Controller webpage.
Cause
The controller is configured with an IP address other than the factory default address.
The controller is configured with an unknown IP address.
The laptop PC is connected to the wrong port on the controller.
Resolution
To determine what IP address the controller has been configured for
- Start a LAN capture on the laptop PC using WireShark or EtherReal
- Power cycle the controller.
- Once the controller has reset it will send out an gratuitous ARP packet that will contain the controllers IP address.
Second Generation Controllers
- Connect a PC directly to the controller alone with a single ethernet cable.
- Verify that the connector cable is connected to the correct port on the laptop PC (Do not use a USB Media convertor)
- Verify that the connector cable is connected to the correct port on the Controller.
- Verify that the IP setting on the PC and the IP setting of the controller are within the same subnet.
- If Web Server Security is enabled on the controller you must use https:// rather than http:// before the IP address.
-
If the controller has an IP reset button
- Hold it down for 60 seconds to restore the factory default IP address.
- Change the IP setting on the PC's network interface to 169.254.1.2
- Attempt to access webpage using the default address 169.254.1.1
- If the controller will not come on line reflash the firmware using RoamIO or Cyberstation.
- Determine if the Web TCP port was changed from the default
Note:
- A controller does not necessarily have to show up as being online in CyberStation in order to be flashed.
- If this will not work try bringing the controller into Cyber on a new test database, then reflashing.
First Generation controllers
- Verify that the serial cable adapter has the correct pin configuration.
- Verify that the cable adapter is not damaged or defective.
- CX9200 Ensure that the pins on the EPROMS that may have been switched from Infinity to Continuum are not bent