Issue
Creation and testing of a Scheduled Action to retime the Sigma controllers.
Environment
Sigma
Scheduled Actions
Retiming controllers.
Cause
The Scheduled Action to retime Sigma controllers does not appear work.
Resolution
Create the Action to Retime the Sigma controllers.
1 - In Sigma Setup, select "General - Scheduled Actions - Actions".
2 - Highlight "Actions" and select "New".
3 - Give the Action a title, "Retime Controllers" for instance.
4 - Highlight the new action, and in the "Select Required Actions" window select, "Retime Devices". Save the changes.
Create the type of schedule you require.
1 - Highlight "Daily" and select "New".
2 - Give the Schedule a title, "Retime Controllers" for instance.
3 - Highlight the new schedule, and in the "Actions" window select, "Retime Controllers".
4 - Select the Days / Times you require, and save the changes.
Testing the operation of the new "Retime Controllers" schedule.
1 - Allow the system to operate normally and then confirm that the controller retime has taken place, by using the "Transaction Logging", or by checking the controller times, to confirm this.
OR
2 - Manually change the PC Time / Date to confirm that the schedule operates correctly.
If using this method then make sure that the PC clock is allowed to pass through midnight automatically. An example of this, would be to set the controllers retiming to take place at 00:05 and then set the PC clock to 23.55. This ensures that the PC time passes through midnight, before the "Scheduled Action" is run at 00:05.