Issue
A GCM has lost its database and an older backup exists. The backup was done with SIGNAL software. Since then, the SIGNAL host computer was replaced. After placing a copy of the older backup in the UPLOAD directory, SIGNAL's download feature does not recognize the file.
Environment
- SIGNAL for Windows 95/98 (version 4.4.1)
- SIGNAL for Windows XP (version 5.0.0)
- GCM-84000 series
- GCM-86000 series
Cause
The updown.dat "index" file used as reference by SIGNAL's download feature does not exist.
It must contain at least one entry indicating that a backup copy of the GCM database exists in the UPLOAD directory.
Resolution
-
Even though the GCM lost its database, use SIGNAL's upload command to create a new backup copy of the GCM.
This process will create a new updown.dat "index' file and a file containing a backup copy of the GCM database. The filename will be similar to: UP016724.G1 - Using Windows Explorer, go to the SIGNAL\UPLOAD directory and rename file UP016724.G1 to test.G1
- Paste a copy of the older backup file and rename it to match the filename created in step 1 (UP016724.G1)
- Return to the SIGNAL desktop and perform a download. SIGNAL will proceed to use the older backup file that was renamed.
- When the download is complete, review the database in the GCM with Terminal Mode to ensure all blocks are working and to make any programming changes.