Issue
Getting the following error “The webpage cannot be found” and “HTTP 404” when attempting to access R2 Enterprise Server’s alarms database via a web browser. Also getting the following errors in the Standard Output Window:
ERROR: Could not open database connection
SQL Exception: Failed to start database 'app'
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SQL Exception: Failed to start database 'app'
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ERROR: Unable to open database
java.lang.IllegalStateException: Database not connected!
Environment
R2 Enterprise Server, WorkPlace Pro (all versions)
Cause
Corrupt server app folder. Due to the corrupt app folder, Database Service never started; so the alarm pages were never created.
Resolution
Stop the server’s database and delete its app folder. A new app folder will be created when the server is restarted.