Issue
Trend logs that are stored in a Xenta Programmable must be uploaded to the Vista Server at certain intervals/when certain capacities of memory are reached. If there are many Xenta Trends all trying to upload to the server simultaneously, it can bog down the network and cause communication problems. This utility will help diagnose these situations by providing a summary of all trends and flagging any areas of concern.
Environment
- Vista Server
- Xenta Programmable controllers
- Xenta 280, 281, 282, 283, 300, 301, 302, 401, 401:B
- Xenta Trend Logs
Cause
- Setting a Xenta trend to log values too frequently
- Setting a Xenta trend to upload at too low of a memory capacity
Resolution
This utility was created by Benjamin Roswall at Schneider Electric Denmark. It is not an official release, nor is it supported by Schneider Electric. While it has been tested and used successfully, it should be used at your own risk.
- Click here to download the TAC Vista Check Log Utility.
- Run the .exe file
- Choose Open File on a .des file (instructions for generating the .des shown below)
- Choose Check Logs, evaluate any highlighted line items.
Create a network description (.des) of Xenta Trends
-
Open the Database Generator
- In Vista Workstation, click on Tools > TAC Vista Database Generator
- Or go to Start > All Programs > Schneider Electric > TAC Tools X.X.X > Database Generator
-
Log in to TAC Vista Server
-
Select Database > Export Data from Database...
-
Click on Browse in the Object box
-
Select Device navigation and select the TAC Vista node you want to analyze. Click OK.
-
Click on Browse in the Object type box. Select "Trend Log - Xenta" in the drop down box. This is VERY important. The check log program will crash if you choose anything else.
-
Leave the text boxes in the Object data box as they are. This is also important. Click on OK.
-
Your export should be generated. Click on OK.
- Save the .des file with File > Save As...
- You can now open the TAC Vista Check Log utility to analyze the trend logs.