When installing an older version of the I/A Series R2 software, the Niagara Installer screen has the Install Niagara option grayed out preventing the complete installation of the software.

Issue

During the installation of the I/A Series R2 software, the first part of the installation completes successfully but when the "Niagara Setup" window is displayed, the "Install Niagara" option is grayed out.  This prevents the user from completing the installation of the software.

Product Line

TAC I/A Series

Environment

Any I/A Series R2 (Niagara) version prior to version 5.14

Cause

All revisions of Niagara R2 prior to 2.301.514 require Microsoft's JVM.  This version of Java is not installed automatically on Windows XPsp3 computers and is automatically uninstalled from the Windows XP computer when Internet Explorer version 7 is first installed on the computer.

To confirm if it is installed, open a Command Prompt window and type "jview" then press Enter. This command will display the current version of Microsoft's JVM (or an error message if it is not installed).

Resolution

  1. Navigate to The Exchange Download Center and download software file Java_Virtual_Machine_for_WinXP.exe
  2. After downloading and installing the JVM, rerun the Setup.exe program for the I/A Series R2 (Niagara) software to complete the installation of the I/A Series R2 software.

The Microsoft Java Virtual Machine and the Sun Java  "Java Runtime Environment" (required for R2 versions 514 and newer) can coexist on the computer and will not interfere with each other.