Cannot login to DBCreate using Windows Authentication

Issue

Trying to run DBCreate and the Windows Authentication does not allow me to login and sysadmin (sa) password not known.

Product Line

TAC I/NET

Environment

I/NET Seven

Windows XP / Windows 7

Cause

This is normally related to the logged in user not having either Administrative privileges to the PC and / or the correct access privileges to the SQL Server.   

Resolution

The best solution is to verify / modify the logged in account is part of the Administrator group and that the Administrator group has access rights to the SQL Server database(s).

Another solution would be to change / modify the sysadmin (SA) password and use the SQL Server authentication. Refer to Lessons Learned Article #2539 or Lessons Learned Article #5390 on how to achieve this. Caution: Note that changing this password may impact on other applications using SQL Server. 

Both of these solutions may also require IT personnel to get involved. 

A possible workaround maybe to run the application at a higher authority level.  To do this perform the following steps:

Windows XP:

  1. Locate Application, in this case DBCreate within Start > Programs> INET
  2. Right-Click on DBCreate - Database Create Utility shortcut and select the option "Run as.."
  3. Login with the Administrator or known user with administrator privileges
  4. Connect using > Windows Authentication should now be possible

Windows7:

  1. Locate Application, in this case DBCreate within Start (Windows7 icon) > All Programs > INET
  2. Right-Click on DBCreate - Database Create Utility shortcut and select "Run as administrator" option
  3. From DBCreate application Connect using > Windows Authentication should now be possible