Issue
Using TimeSync Service in an UNC-520 to directly connect to an internet time sync service, but can not sync time in the UNC. The following message is displayed in the UNC’s Standard Output Windows when the TimeSyncService debug is turned on:
"Error: java.SocketException
Message: Timesync aborting: not all servers responded."
Environment
Niagara R2 all versions, UNC520, UNC-410, Enterprise Server
Cause
The port used by R2 TimeSyncService is typically blocked somewhere on the network. Niagara R2 TimeSyncService uses TCP port 37 by default. Port is block by network domain security policy.
Resolution
Make sure that all three of the client’s TimeProtocolServer properties are filled in. If only one TimeSync server is being used, enter it for all three TimeSyncServer properties.
If the UNC or Enterprise Server still do not sync to the time sync server, then the port may be blocked. The port used by the TImeSyncService must be open. Contacts the site’s IT department and make sure port 37, or whatever port the time sync is configured for, is opened.
NOTE: I/A Series R2 utilizes TCP port 37 with the standard TIME format (RFC-868). The official NIST website indicates the TIME protocol using TCP 37 will no longer be supported on March 1, 2013. R2 does not support other formats (e.g. UDP or NTP). The recommendation is to configure the Enterprise Server as a time sync server only and configure the UNCs to synchronize to the Enterprise Server's computer time. The computer running the Enterprise Server will then need to use the standard Windows time sync mechanism and not the R2 time sync mechanism to maintain the time for the computer.