Issue
The Alarms system variable in a controller contains a value other than zero but Active Alarm list view in CyberStation does not show any active alarms from that controller, How can I find out which alarms are active in the controller?
Environment
CyberStation
All CXs
All I2 devices
Cause
Active alarm can be determined by creating a column in the default list view to store alarm information from 'Live' source.
Resolution
- Right click on InfinityNumeric and select 'View' to launch the default list view for the class.
- Edit the list view and add a column for the 'AlarmValue' attribute and set the column source to 'Live'
-
Run the list view and inspect the AlarmValue:
Blank = No active alarm on point
Alm1 = the first alarm is active on point.
Alm2 = the second alarm is active on point
...
Alm8 = the 8th alarm is active on the point