Unable to open I/A Series R2 Workplace Pro or the R2 Admin Tool on a specific computer.

Issue

Unable to open I/A Series R2 Workplace Pro or the R2 Admin Tool on a specific computer.  No error window popups are seen.  When you attempt to open the program, it flashes its opening screen briefly then dies.

Product Line

TAC I/A Series

Environment

I/A Series R2 WorkPlace Pro

I/A Series R2 Admin tool

Cause

Insufficient computer memory to allow standard 1024mb to be reserved for the Java heap.

Resolution

To resolve this issue, you can adjust the Java heap settings in the nre.properties file. It is important that you only make the changes as detailed below. Make a backup copy of this file before proceeding.

  1. Locate the file nre.properties in \niagara\\nre\lib
  2. Open the nre.properties file using a text editor program (Notepad).
  3. Modify the java.options=-Xmx1024MB to java.options=-Xmx768MB leaving other parameters in the file unchanged.
  4. Save, close the file and restart the software.