Issue
Need an indication when the SQL Server has a hardware or a network failure and is unable to communicate to the Continuum Cyberstation's.
Environment
Continuum Cyberstation
SQL Server
Cause
Customers IT Department wants to know when the Continuum SQL Server has a hardware or a network failure and is unable to communicate to the Continuum Cyberstations. When Cyberstation loses the connection to the SQL server it loses all functionality and will not be able to send alarms as emails to annunciate that there is a problem.
Resolution
The best solution for this is to monitor the Server and/or Workstations to determine if they have failed by using SNMP traps that feed back each systems status into the existing IT monitoring systems (assuming they already monitor SNMP traps on their other equipment).
On Windows Server you can setup traps to monitor specific applications on remote PC's as well as the general on/off state of that PC. See Microsoft article below as an example of this.
http://support.microsoft.com/kb/324263
Alternatively, when the SQL server goes offline to the Workstations running the Continuum application, the workstations will see that the server has gone offline and raise a disconnection message at the Workstation. Continuum will attempt to re-establish this connection to the server, if it is unsuccessful then the application will close. If they monitor the Workstations continuously then this message can be seen on the Cyberstations and would be another visual indication that the connection to the server has been lost.