Remote Desktop Protocol (RDP) / Remote Desktop Connection (RDC) and I/NET

Issue

I/NET Server (Remote Client Configuration) can not connect to I/NET network even though the workstations (other Hosts) can.

All workstations (I/NET hosts) transactions are not updating, but alarms and messages are.

Product Line

TAC I/NET

Environment

  • I/NET Seven
  • Remote Client configuration
  • Remote Desktop / Terminal Services

Cause

Unless the Remote Desktop is configured for a single user session, then its extremely likely that multiple instances of the INetIoSrv.exe is established, this will cause issues with I/NET such as described above.  It is strongly recommended to use an alternative method of remote connection.

Resolution

Alternative remote connection should be used, we would recommend VNC, Ultra VNC, WinVNC or similar.  This will ensure that multiple user terminal sessions will not open.

Remote Desktop can be configured for single user operation also, but the above software packages are the preferred remote connection method.  See the following external site on "How to force a single session Remote Desktop session per user".
http://remotedesktoprdp.com/Force-Single-Session-Allow-Multiple-Sessions-Per-User.aspx